DNS Issues Impacting Multiple Oforce Sites

Incident Report for OpenforcePublic

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 07:25 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 03:15 MST

Investigating

We are currently experiencing DNS issues impacting site resolution
Posted Jul 28, 2026 - 02:33 MST
This incident affected: IC Manage, IC Insure, and IC Pay.