AWS Outage - Impacting multiple services

Incident Report for OpenforcePublic

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:57 MST

Update

AWS is reporting their outage as fixed and we are seeing our internal services errors reduce and stabilize. This includes logging in, completing enrollments and processing settlements.

We are continuing to monitor the AWS outage and the impacts on our system.
Posted Oct 20, 2025 - 13:34 MST

Monitoring

Services and functionality have been restored and are returning to normal. We will continue to monitor the impact of today’s AWS outage.
Posted Oct 20, 2025 - 13:16 MST

Update

We are seeing a reduction in login and enrollment errors. We are still seeing encountering issues when submitting settlements due to the AWS Outages.

We are continuing to monitor the AWS outages and will provide updates as we have more information.
Posted Oct 20, 2025 - 12:31 MST

Update

The AWS outage is still ongoing and causing issues when logging in, going through an enrollment, and submitting settlements.

We are continuing to monitor the AWS outages and will provide updates as we have more information.
Posted Oct 20, 2025 - 10:58 MST

Identified

The AWS outage is still ongoing and causing a few pages to fail within ICM. We are continuing to monitor the AWS outages and assess the impacts to our services.

We will continue to provide updates as we have more information.
Posted Oct 20, 2025 - 09:12 MST

Investigating

The ongoing AWS outage is creating intermittent issues when navigating through ICM. The team is currently monitoring the AWS outages and investigating impacts to our systems.

We will continue to provide updates as we have more information.
Posted Oct 20, 2025 - 08:05 MST

Update

All of our critical services remain fully operational. We are continuing to monitor the AWS outages to ensure critical services remain functioning.
Posted Oct 20, 2025 - 07:57 MST

Update

All of our critical system functions continue to remain operational. We're continuing to monitor the AWS outage to ensure all of our services remain stable.
Posted Oct 20, 2025 - 06:46 MST

Update

All of our critical system functions remain operational. We're continuing to monitor the AWS outage to ensure all of our services remain stable.
Posted Oct 20, 2025 - 05:01 MST

Update

The AWS outage is ongoing and showing degraded performance in some areas. We are showing all our services operational, but will continue to monitor to ensure services remain stable.
Posted Oct 20, 2025 - 04:11 MST

Update

We are showing all services as operational, but will continue to monitor to ensure services remain stable.
Posted Oct 20, 2025 - 03:21 MST

Monitoring

AWS experienced an outage starting at 3 AM ET. This outage impacted multiple Openforce services. The majority of services have been restored while we monitor the remaining few.
Posted Oct 20, 2025 - 02:55 MST
This incident affected: IC Manage, IC Insure, and IC Pay.